summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-02-17 18:09:49 +0000
committerLudovic Courtès <ludo@gnu.org>2022-02-18 14:14:39 +0100
commit33f2e862c7bf87e45d12dbd3e87501a64d5e69fe (patch)
tree5cadb0489ebb19f3266d2df9a3a7156015b3e1ec /gnu/packages
parentb3d7eae08ee71674ebcf6c6dc5ef575f35493240 (diff)
downloadguix-33f2e862c7bf87e45d12dbd3e87501a64d5e69fe.tar.gz
gnu: umockdev: Use G-expressions.
While we're at it, remove the trailing #t.

* gnu/packagers/check.scm (umockdev)[arguments]<#:phases>: Change to a G-exp.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 06adf20c36..8d422d4b85 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2885,13 +2885,12 @@ provides a simple way to achieve this.")
                 "0xmi24ckpps32k7hc139psgbsnsf4g106sv4l9m445m46amkxggd"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-test
-           (lambda _
-             (substitute* "tests/test-umockdev.c"
-               (("/run") "/tmp"))
-             #t)))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'fix-test
+                 (lambda _
+                   (substitute* "tests/test-umockdev.c"
+                     (("/run") "/tmp")))))))
     (native-inputs
      (list vala
            gobject-introspection