summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2021-01-04 02:00:14 +0100
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2021-02-28 23:16:23 +0100
commit3d5c5cf611cc09c03e9d641094d86e3afc96d6c6 (patch)
tree3abb68b85cfb26a0e1550fa950f9534e193b498b /gnu/packages
parentf815e88ed0f1cc0c5dd391fbc450710008483b53 (diff)
downloadguix-3d5c5cf611cc09c03e9d641094d86e3afc96d6c6.tar.gz
gnu: Add ruby-jekyll-seo-tag.
* gnu/packages/ruby.scm (ruby-jekyll-seo-tag): New variable.

Signed-off-by: Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index fc946a705e..231402d9f5 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12333,3 +12333,28 @@ a sitemaps.org compliant sitemap for your Jekyll site.")
     (home-page
       "https://github.com/jekyll/jekyll-sitemap")
     (license license:expat)))
+
+(define-public ruby-jekyll-seo-tag
+  (package
+   (name "ruby-jekyll-seo-tag")
+   (version "2.7.1")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (rubygems-uri "jekyll-seo-tag" version))
+     (sha256
+      (base32
+       "0fsi75hymk2wswy216fs224p5ycrzjw1kshw1bsl5czhv42wr2w3"))))
+   (build-system ruby-build-system)
+   (arguments
+    `(#:tests? #false))
+   (propagated-inputs
+    `(("jekyll" ,jekyll)))
+   (synopsis
+    "Jekyll plugin to add metadata tags for search engines and social networks")
+   (description
+    "This package provides a Jekyll plugin to add metadata tags for search engines
+and social networks to better index and display your site's content.")
+   (home-page
+    "https://github.com/jekyll/jekyll-seo-tag")
+   (license license:expat)))