summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-22 16:58:17 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:47 -0500
commit40b67a1f2a49c3a00f30b943dcd4e1de5a62632f (patch)
treeabf7171c7669702383a7f2031ccaf0148fcd54ed /gnu/packages
parent220a153c2fa70e4b02ae0e96502fd18a14bf1834 (diff)
downloadguix-40b67a1f2a49c3a00f30b943dcd4e1de5a62632f.tar.gz
gnu: linkchecker: Do not set PYTHONPATH.
* gnu/packages/web.scm (linkchecker): Remove trailing #t.
[phases]: Do not reorder the check phase after the install phase.
{check}: Do not set PYTHONPATH.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 029a05df49..44405d4223 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -47,6 +47,7 @@
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6431,23 +6432,13 @@ Instagram and YouTube.")
      `(#:python ,python-2
        #:phases
        (modify-phases %standard-phases
-         ;; Move the 'check phase to after 'install, so that the installed
-         ;; library can be used
-         (delete 'check)
-         (add-after 'install 'check
+         (replace 'check
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
-               ;; Set PYTHONPATH so that the installed linkchecker is used
-               (setenv "PYTHONPATH"
-                       (string-append out "/lib/python2.7/site-packages"
-                                      ":"
-                                      (getenv "PYTHONPATH")))
                ;; Remove this directory to avoid it being used when running
                ;; the tests
                (delete-file-recursively "linkcheck")
-
-               (invoke "py.test" "tests"))
-             #t)))))
+               (invoke "py.test" "tests")))))))
     (home-page "https://linkcheck.github.io/linkchecker")
     (synopsis "Check websites for broken links")
     (description "LinkChecker is a website validator.  It checks for broken