summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-24 11:24:57 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:11:47 +0000
commit499dbe0f3c4f9a86b5e44aa415de0bd18146b216 (patch)
tree791021dc87abc0ce68c932fb44002de0022676e9 /gnu/packages
parent881a5d26b2fdf9ccb222b26b2a533cd09ffc62c8 (diff)
downloadguix-499dbe0f3c4f9a86b5e44aa415de0bd18146b216.tar.gz
gnu: dbus-cairo: Add missing bash-minimal input.
If absent, this causes the 'glib-or-gtk-wrap' phase to fail.

* gnu/packages/glib.scm
  (cairo)[inputs]: Add "bash-minimal", but only when cross-compiling
  to avoid a world-rebuild.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 876071235e..900ee0a1b9 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -61,6 +61,7 @@
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages texinfo)
@@ -174,7 +175,11 @@ tools have full access to view and control running applications.")
        ("pkg-config" ,pkg-config)
        ("python" ,python-wrapper)))
     (inputs
-     `(("drm" ,libdrm)
+     ;; TODO(core-updates): make this unconditional
+     `(,@(if (%current-target-system)
+             `(("bash-minimal" ,bash-minimal)) ; for glib-or-gtk-wrap
+             '())
+       ("drm" ,libdrm)
        ("ghostscript" ,ghostscript)
        ("libspectre" ,libspectre)
        ("poppler" ,poppler)))