summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-06-05 23:05:02 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-06-06 00:25:49 +0200
commit524c64152a8458915f42eb4a74b764eb2ab93966 (patch)
tree09bda1dfeeb80414d5a0ade11fc7b22fb29b16cc /gnu/packages
parent08b55f14435fa04e7c21c066ed35d9494deccaa9 (diff)
downloadguix-524c64152a8458915f42eb4a74b764eb2ab93966.tar.gz
gnu: Add soapysdr.
* gnu/packages/radio.scm (soapysdr): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/radio.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 5fbddc102b..a3cbe99380 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -258,6 +258,35 @@ To install the airspyhf udev rules, you must extend @code{udev-service-type}
 with this package.  E.g.: @code{(udev-rules-service 'airspyhf airspyhf)}")
     (license license:bsd-3)))
 
+(define-public soapysdr
+  (package
+    (name "soapysdr")
+    (version "0.8.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pothosware/SoapySDR")
+             (commit (string-append "soapy-sdr-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1dy25zxk7wmg7ik82dx7h3bbbynvalbz1dxsl7kgm3374yxhnixv"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("python" ,python)
+       ("swig" ,swig)))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "SOAPY_SDR_PLUGIN_PATH")
+            (files (list (string-append "lib/SoapySDR/modules"
+                                        (version-major+minor version)))))))
+    (home-page "https://github.com/pothosware/SoapySDR/wiki")
+    (synopsis "Vendor and platform neutral SDR support library")
+    (description
+     "SoapySDR is a library designed to support several kinds of software
+defined radio hardware devices with a common API.")
+    (license license:boost1.0)))
+
 (define-public chirp
   (package
     (name "chirp")