summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-12-24 16:00:15 +0100
committerRutger Helling <rhelling@mykolab.com>2017-12-24 16:07:52 +0100
commit6cd46747e7e09fd9b89ef236443a8d71e2559b5d (patch)
tree64ce8a29e84dcd4c4e8f0b5b56b1605e65833f76 /gnu/packages
parentc154c97f90d925b8f6b29ee0c930e4a6c8e1f218 (diff)
downloadguix-6cd46747e7e09fd9b89ef236443a8d71e2559b5d.tar.gz
gnu: Add wine64-staging.
* gnu/packages/wine.scm (wine64-staging): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wine.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 361e597472..b4a303df93 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -216,3 +216,20 @@ integrated into the main branch.")
     ;; both GPL3+ and Apache 2 License.
     (license
      (list license:lgpl2.1+ license:silofl1.1 license:gpl3+ license:asl2.0))))
+
+(define-public wine64-staging
+  (package
+    (inherit wine-staging)
+    (name "wine64-staging")
+    (arguments
+     `(#:make-flags
+       (list "SHELL=bash"
+             (string-append "libdir=" %output "/lib"))
+       #:configure-flags
+       (list "--enable-win64"
+             (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
+       ,@(strip-keyword-arguments '(#:configure-flags #:make-flags #:system)
+                                  (package-arguments wine-staging))))
+    (synopsis "Implementation of the Windows API (staging branch, 64-bit
+version)")
+    (supported-systems '("x86_64-linux" "aarch64-linux"))))