summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-13 17:41:13 -0400
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:31 -0400
commit78d1b85a54331266f1f8ff5708f99eaa3ed37462 (patch)
tree53e7b87ad1c4e23441404bb0b114efa014db525d /gnu/packages
parentd8742c0af3d30afbb285ed490c91c9e7a434d5ed (diff)
downloadguix-78d1b85a54331266f1f8ff5708f99eaa3ed37462.tar.gz
gnu: Provide the full 'rollinghash' Go library.
* gnu/packages/syncthing.scm
(go-github-com-chmduquesne-rollinghash-adler32): Replace with ...
(go-github-com-chmduquesne-rollinghash): ... new variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/syncthing.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index dcf8ea8999..ba85b5ba07 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -658,11 +658,14 @@ generation.")
       (home-page "https://github.com/vitrun/qart")
       (license bsd-3))))
 
-(define-public go-github-com-chmduquesne-rollinghash-adler32
+;; XXX Syncthing actually imports 'github.com/chmduquesne/rollinghash/adler32'.
+;; Normally we'd package this module indpendenctly but the adler32 module itself
+;; imports 'github.com/chmduquesne/rollinghash/', so this is the easy way out.
+(define-public go-github-com-chmduquesne-rollinghash
   (let ((commit "a60f8e7142b536ea61bb5d84014171189eeaaa81")
         (revision "0"))
     (package
-      (name "go-github-com-chmduquesne-rollinghash-adler32")
+      (name "go-github-com-chmduquesne-rollinghash")
       (version (git-version "4.0.0" revision commit))
       (source
         (origin
@@ -676,11 +679,10 @@ generation.")
             "0fpaqq4zb0wikgbhn7vwqqj1h865f5xy195vkhivsp922p7qwsjr"))))
       (build-system go-build-system)
       (arguments
-       '(#:import-path "github.com/chmduquesne/rollinghash/adler32"
-         #:unpack-path "github.com/chmduquesne/rollinghash"))
-      (synopsis "Adler-32 rolling hash in Go")
-      (description "This package provides a Go implementation of the Adler-32
-rolling hash.")
+       '(#:import-path "github.com/chmduquesne/rollinghash/"))
+      (synopsis "Rolling hashes in Go")
+      (description "This package provides a Go implementation of several rolling
+hashes.")
       (home-page "https://github.com/chmduquesne/rollinghash")
       (license expat))))