summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-11-09 04:13:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-09 09:53:43 +0100
commit8b91760f2080d9482ce208ea15fd3adf05eb3663 (patch)
tree7588843e0d1723a645feaf95a0784996553bff65 /gnu/packages
parentfdc9e1b27edfb3df51d391364bcbc50e9cd1de40 (diff)
downloadguix-8b91760f2080d9482ce208ea15fd3adf05eb3663.tar.gz
gnu: Add r-pals.
* gnu/packages/cran.scm (r-pals): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index eff789ba8d..4b5b4f1cd4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1661,6 +1661,31 @@ consistent fashion.  It seeks to combine functionality from lower level
 functions which can speed up workflow.")
     (license license:gpl2)))
 
+(define-public r-pals
+  (package
+    (name "r-pals")
+    (version "1.7")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "pals" version))
+              (sha256
+               (base32
+                "18pbivmqs9yqsb6p8anv42alny0njaq3dajibhzysax0b7rsk2js"))))
+    (properties `((upstream-name . "pals")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-colorspace
+           r-dichromat
+           r-mapproj
+           r-maps))
+    (native-inputs (list r-knitr))
+    (home-page "https://kwstat.github.io/pals/")
+    (synopsis "Color palettes, color maps, and tools to evaluate them")
+    (description
+     "This package provides a comprehensive collection of color
+palettes, color maps, and tools to evaluate them.")
+    (license license:gpl3)))
+
 (define-public r-paralleldist
   (package
     (name "r-paralleldist")