summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-06-11 09:52:21 +0200
committerRutger Helling <rhelling@mykolab.com>2018-06-11 18:22:10 +0200
commitc7c86de6698ce595c26babd08fe0a0a5b18cfea4 (patch)
treed0f33c99e8b97a6cec546a47c1efc72967e6952e /gnu/packages
parent6da97043ea11490792c658255b5413c10e295b53 (diff)
downloadguix-c7c86de6698ce595c26babd08fe0a0a5b18cfea4.tar.gz
gnu: spirv-headers: Update to 3ce3e49.
* gnu/packages/vulkan.scm (spirv-headers): Update to 3ce3e49. Use INVOKE.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/vulkan.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index c38a5ae211..293a3abbdd 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -37,8 +37,8 @@
 (define-public spirv-headers
   ;; Keep updated in accordance with
   ;; https://github.com/google/shaderc/blob/known-good/known_good.json
-  (let ((commit "061097878467b8e040fbf153a837d844ef9f9f96")
-        (revision "2"))
+  (let ((commit "3ce3e49d73b8abbf2ffe33f829f941fb2a40f552")
+        (revision "3"))
     (package
       (name "spirv-headers")
       (version (string-append "0.0-" revision "." (string-take commit 9)))
@@ -50,7 +50,7 @@
                (commit commit)))
          (sha256
           (base32
-           "0bf9h6xc5fkncxnadwmqvpsjh7sdgns6is8prv1gvlfzrkvpjj17"))
+           "0yk4bzqifdqpmdxkhvrxbdqhf5ngkga0ig1yyz7khr7rklqfz7wp"))
          (file-name (string-append name "-" version "-checkout"))))
       (build-system cmake-build-system)
       (arguments
@@ -58,10 +58,10 @@
          #:phases (modify-phases %standard-phases
                     (replace 'install
                       (lambda* (#:key outputs #:allow-other-keys)
-                        (zero? (system* "cmake" "-E" "copy_directory"
+                        (invoke "cmake" "-E" "copy_directory"
                                         "../source/include/spirv"
                                         (string-append (assoc-ref outputs "out")
-                                                       "/include/spirv"))))))))
+                                                       "/include/spirv")))))))
       (home-page "https://github.com/KhronosGroup/SPIRV-Headers")
       (synopsis "Machine-readable files from the SPIR-V Registry")
       (description