summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 10:41:10 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:43:37 -0400
commitd244c18eef456cd6cfa4e21cfaebcab595797ab2 (patch)
tree8a29a04f365e88918abd92df58a1419f831fcc1b /gnu/packages
parent4cd5cb19c059b1bcd97507f70104c8688cc0390a (diff)
downloadguix-d244c18eef456cd6cfa4e21cfaebcab595797ab2.tar.gz
gnu: gdk-pixbuf: Enable jasper support.
* gnu/packages/gtk.scm (gdk-pixbuf) [arguments]<#:configure-flags>[-Djasper]: New flag.
[inputs]: Add jasper.

Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 52ee8575cd..2c1a9e84fc 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -593,7 +593,7 @@ highlighting and other features typical of a source code editor.")
     (arguments
      `(#:meson ,meson-0.55
        #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
-       #:configure-flags '("-Dinstalled_tests=false")
+       #:configure-flags '("-Dinstalled_tests=false" "-Djasper=true")
        #:phases
        (modify-phases %standard-phases
          ;; The slow tests take longer than the specified timeout.
@@ -611,7 +611,8 @@ highlighting and other features typical of a source code editor.")
        ;; Used for testing and required at runtime.
        ("shared-mime-info" ,shared-mime-info)))
     (inputs
-     `(("libjpeg" ,libjpeg-turbo)
+     `(("jasper" ,jasper)
+       ("libjpeg" ,libjpeg-turbo)
        ("libpng"  ,libpng)
        ("libtiff" ,libtiff)))
     (native-inputs