summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-01 19:06:42 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-01 19:06:42 +0100
commite56186df593ea6d474aa3ea7faf0efcd31f75857 (patch)
tree8bded2b3eb78ee062bff45a74cba5ae5d4f4e74d /gnu/packages
parentff9f2463f9c604c402ccbebdeba41dd22a915e6c (diff)
downloadguix-e56186df593ea6d474aa3ea7faf0efcd31f75857.tar.gz
gnu: cutter: Fix build by depending on older radare2.
* gnu/packages/engineering.scm (radare2-for-cutter): New variable. Version 5.0.0.
(cutter)[inputs]: Move from radare2 to radare2-for-cutter.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/engineering.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 99c9f216ef..59c424c9da 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2393,6 +2393,21 @@ analysis and AC analysis.  The engine is designed to do true mixed-mode
 simulation.")
     (license license:gpl3+)))
 
+(define-public radare2-for-cutter
+  (package
+    (inherit radare2)
+    (name "radare2")
+    (version "5.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/radareorg/radare2")
+                    (commit version)))
+              (sha256
+               (base32
+                "0aa7c27kd0l55fy5qfvxqmakp4pz6240v3hn84095qmqkzcbs420"))
+              (file-name (git-file-name name version))))))
+
 (define-public cutter
   (package
     (name "cutter")
@@ -2428,7 +2443,9 @@ simulation.")
      `(("qtbase" ,qtbase)
        ("qtsvg" ,qtsvg)
        ("openssl" ,openssl)
-       ("radare2" ,radare2)))
+       ;; Depends on radare2 4.5.1 officially, builds and works fine with
+       ;; radare2 5.0.0 but fails to build with radare2 5.1.1.
+       ("radare2" ,radare2-for-cutter)))
     (home-page "https://github.com/radareorg/cutter")
     (synopsis "GUI for radare2 reverse engineering framework")
     (description "Cutter is a GUI for radare2 reverse engineering framework.