summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-01 07:35:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-31 04:54:50 +0200
commite80c05ac3eca7438b8f2fd43c712e001e455268d (patch)
tree39bc138042d7598f11671f8265104fa77369bb28 /gnu/packages
parent512f22f9e8ffe4ac30f09758427926be51de6b23 (diff)
downloadguix-e80c05ac3eca7438b8f2fd43c712e001e455268d.tar.gz
gnu: ffmpeg: Use INVOKE.
* gnu/packages/video.scm (ffmpeg)[arguments]: Substitute INVOKE for
SYSTEM*.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/video.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8464370d28..03bde3ff61 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -756,13 +756,13 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
                 (("#! /bin/sh") (string-append "#!" (which "sh"))))
               (setenv "SHELL" (which "bash"))
               (setenv "CONFIG_SHELL" (which "bash"))
-              (zero? (apply system*
-                            "./configure"
-                            (string-append "--prefix=" out)
-                            ;; Add $libdir to the RUNPATH of all the binaries.
-                            (string-append "--extra-ldflags=-Wl,-rpath="
-                                           out "/lib")
-                            configure-flags)))))
+              (apply invoke
+                     "./configure"
+                     (string-append "--prefix=" out)
+                     ;; Add $libdir to the RUNPATH of all the binaries.
+                     (string-append "--extra-ldflags=-Wl,-rpath="
+                                    out "/lib")
+                     configure-flags))))
          (add-before
           'check 'set-ld-library-path
           (lambda _