summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2017-08-12 17:19:41 +0300
committerManolis Ragkousis <manolis837@gmail.com>2017-08-17 19:40:33 +0300
commite9a599cdce9998973e30e3e1d28d1dad072ec8d5 (patch)
tree1c0ad507ceef1c635d839408a7b123d105fa769c /gnu/packages
parent42d0d13de841b424fc3a8ec6d0c2f2835757a615 (diff)
downloadguix-e9a599cdce9998973e30e3e1d28d1dad072ec8d5.tar.gz
gnu: Add OpenMW.
* gnu/packages/game-development.scm (openmw): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/game-development.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 13e26c04ff..95f8697b42 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -978,3 +978,44 @@ and 3D applications.  The main goals of mygui are: speed, flexibility and ease
 of use.")
     (home-page "http://mygui.info/")
     (license license:expat)))
+
+(define-public openmw
+  (package
+    (name "openmw")
+    (version "0.42.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://github.com/OpenMW/openmw/archive/"
+                       name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1pla8016lpbg8cgm9kia318a860f26dmiayc72p3zl35mqrc7g7w"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f                      ; No test target
+       #:configure-flags
+       (list "-DDESIRED_QT_VERSION=5")))
+    (native-inputs
+     `(("boost" ,boost)
+       ("doxygen" ,doxygen)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("bullet" ,bullet)
+       ("ffmpeg" ,ffmpeg)
+       ("libxt" ,libxt)
+       ("mygui" ,mygui)
+       ("openal" ,openal)
+       ("openscenegraph" ,openscenegraph)
+       ("qtbase" ,qtbase)
+       ("sdl" ,sdl2)
+       ("unshield" ,unshield)))
+    (synopsis "Free software re-implementation of the RPG Morrowind engine")
+    (description
+     "OpenMW is a free, open source and modern engine which reimplements and
+extends the one that runs the 2002 open-world RPG Morrowind.  The engine comes
+with its own editor, called OpenMW-CS which allows the user to edit or create
+their own original games.")
+    (home-page "https://openmw.org")
+    (license license:gpl3)))