summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-16 17:21:24 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 22:47:24 -0500
commitf0b6c5d8fe56b9d2c6b8e768af4a857bad83d22e (patch)
tree4ca2c74b4ffc3739a3ef8bf16dceae6f73a92816 /gnu/packages
parent24d56899a1fd329f2edf2c3d32d82ce7c158ace1 (diff)
downloadguix-f0b6c5d8fe56b9d2c6b8e768af4a857bad83d22e.tar.gz
gnu: Add libxshmfence.
* gnu/packages/xorg.scm (libxshmfence): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xorg.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index fcefebffc5..3d8d02aaa9 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -989,6 +989,29 @@ autotools system.")
     (license license:x11)))
 
 
+(define-public libxshmfence
+  (package
+    (name "libxshmfence")
+    (version "1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://xorg/individual/lib/"
+                    name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1gnfb1z8sbbdc3xpz1zmm94lv7yvfh4kvip9s5pj37ya4llxphnv"))))
+    (build-system gnu-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("xproto" ,xproto)))
+    (home-page "http://xorg.freedesktop.org")
+    (synopsis "X shared memory fences")
+    (description
+     "This library provides an interface to shared-memory fences for
+synchronization between the X server and direct-rendering clients.")
+    (license license:x11-style)))
+
+
 (define-public libfontenc
   (package
     (name "libfontenc")