summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-10-28 15:41:31 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-29 08:34:29 +0100
commit0bb322014084ee76f193bbc3348f29479f014e23 (patch)
treede5b9fcc598c1984f7b909e57263bb3f17de110c /gnu/packages
parent2be85c4531adcf2b59641b75e66c458b895e5a96 (diff)
downloadguix-0bb322014084ee76f193bbc3348f29479f014e23.tar.gz
gnu: Add python-shellingham.
* gnu/packages/python-xyz.scm (python-shellingham): New public variable.

Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1ed79a9a4f..edca719547 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10644,6 +10644,26 @@ create new TOML documents from scratch using the provided helpers.  Part of the
 implementation as been adapted, improved and fixed from Molten.")
     (license license:expat)))
 
+(define-public python-shellingham
+  (package
+    (name "python-shellingham")
+    (version "1.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "shellingham" version))
+       (sha256
+        (base32
+         "1q7kws7w4x2hji3g7y0ni9ddk4sd676ylrb3db54gbpys6xj6nwq"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/sarugaku/shellingham")
+    (synopsis "Tool to detect surrounding shell")
+    (description
+     "Shellingham detects what shell the current Python executable is
+running in.")
+    (license license:isc)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")