summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-19 01:05:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-19 01:28:27 +0100
commit1c1b67a3c91cd46241dee9c556d326e11b1d9ce2 (patch)
tree5d9d1efae157669b212e6db828ba6265f69e76c7 /gnu/packages
parent7b6ff42aa3cf9398213d3c1f0e5f87c45a9730df (diff)
downloadguix-1c1b67a3c91cd46241dee9c556d326e11b1d9ce2.tar.gz
gnu: thefuck: Correct inputs and disable tests.
* gnu/packages/admin.scm (thefuck)[arguments]: Set #:tests? #f.
[inputs]: Move everything to ...
[propagated-inputs]: ... here. Remove duplicate [inputs] and python-setuptools.
[native-inputs]: Add python-pytest, python-pytest-mock and python-mock.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm21
1 files changed, 16 insertions, 5 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 69c04dc139..6e913d2cd0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1697,15 +1697,26 @@ throughput (in the same interval).")
                (base32
                 "04q2cn8c83f6z6wn1scla1ilrpi5ssjc64987hvmwfvwvb82bvkp"))))
     (build-system python-build-system)
-    (inputs
+    (arguments
+     '(#:tests? #f))
+       ;; FIXME: 10 test failures. Some require newer pytest (> 2.9.2).
+       ;; Others need more work. Un-comment the below to run the tests.
+       ;; #:phases
+       ;; (modify-phases %standard-phases
+       ;;   (replace 'check
+       ;;     (lambda _
+       ;;       ;; Some tests need write access to $HOME.
+       ;;       (setenv "HOME" "/tmp")
+       ;;       (zero? (system* "py.test" "-v")))))))
+    (propagated-inputs
      `(("python-colorama" ,python-colorama)
        ("python-decorator" ,python-decorator)
        ("python-psutil" ,python-psutil)
        ("python-six" ,python-six)))
-    (inputs
-     ;; Requires setuptools >= 17.1 due to some features used, while our
-     ;; python currently only includes 12.0. TODO: Remove this input.
-     `(("python-setuptools" ,python-setuptools)))
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-mock" ,python-pytest-mock)))
     (home-page "https://github.com/nvbn/thefuck")
     (synopsis "Correct mistyped console command")
     (description