summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-09 12:44:08 +0200
committerMarius Bakke <marius@gnu.org>2021-05-09 20:03:04 +0200
commit3cf1afb7e7249992b2db2f4f00899fd22237e89a (patch)
tree06afb3bdda8241a52f9bd2f4dcbe0515a00274e0 /gnu/packages
parenta605ef3ce9dbd6b79dd9322f89d9facaf875b487 (diff)
downloadguix-3cf1afb7e7249992b2db2f4f00899fd22237e89a.tar.gz
gnu: cross-kernel-headers: Fix build.
This fixes a regression introduced in
0e2251fcf8189a4f642074d3aa898221b29c3a55, as "make headers_check" does not
actually build the headers in newer versions, instead "make headers_install"
built them as a side effect.

* gnu/packages/cross-base.scm (cross-kernel-headers)[arguments]: Adjust build
phase to call the correct Make target.  While at it, migrate to MODIFY-PHASES.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cross-base.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 6df36966c6..9487ac9238 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2016, 2019 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2016 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2019 Carl Dong <contact@carldong.me>
 ;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
@@ -341,15 +341,18 @@ target that libc."
            `(#:implicit-cross-inputs? #f
              ,@(package-arguments linux-headers))
          ((#:phases phases)
-          `(alist-replace
-            'build
-            (lambda _
-              (setenv "ARCH" ,(system->linux-architecture target))
-              (format #t "`ARCH' set to `~a' (cross compiling)~%" (getenv "ARCH"))
-
-              (invoke "make" ,(system->defconfig target))
-              (invoke "make" "mrproper" "headers_check"))
-            ,phases))))
+          `(modify-phases ,phases
+             (replace 'build
+               (lambda _
+                 (setenv "ARCH" ,(system->linux-architecture target))
+                 (format #t "`ARCH' set to `~a' (cross compiling)~%"
+                         (getenv "ARCH"))
+
+                 (invoke "make" ,(system->defconfig target))
+                 (invoke "make" "mrproper"
+                         ,@(if (version>=? (package-version linux-headers) "5.3")
+                               '("headers")
+                               '("headers_check")))))))))
       (native-inputs `(("cross-gcc" ,xgcc)
                        ("cross-binutils" ,xbinutils)
                        ,@(package-native-inputs linux-headers)))))