summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-21 11:47:17 +0000
committerLeo Famulari <leo@famulari.name>2016-12-28 22:41:53 -0500
commit789de5e279ba077340a4e28a772be2f4a3c92457 (patch)
tree8da79b3b7037c35d9e751158e3a75301dd7767d5 /gnu/packages
parenta0e41de4abdf23c51924ada15e5d28d6c22d09f2 (diff)
downloadguix-789de5e279ba077340a4e28a772be2f4a3c92457.tar.gz
gnu: Add python-straight-plugin.
* gnu/packages/python.scm (python-straight-plugin, python2-straight-plugins):
New variables.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d74438d930..980c2390bd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6102,6 +6102,28 @@ term.js Javascript terminal emulator library.")
           ,python2-backport-ssl-match-hostname)
           ,@(package-propagated-inputs terminado))))))
 
+(define-public python-straight-plugin
+  (package
+    (name "python-straight-plugin")
+    (version "1.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "straight.plugin" version))
+       (sha256
+        (base32
+         "069pjll4383p4kkgvcc40hgyvf79j2wdbpgwz77yigzxksh1gj62"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/ironfroggy/straight.plugin")
+    (synopsis "Simple namespaced plugin facility")
+    (description "Straight Plugin provides a type of plugin you can create from
+almost any existing Python modules, and an easy way for outside developers to
+add functionality and customization to your projects with their own plugins.")
+    (license license:expat)))
+
+(define-public python2-straight-plugin
+  (package-with-python2 python-straight-plugin))
+
 (define-public python-fonttools
   (package
     (name "python-fonttools")