summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-26 09:29:01 +0200
committerRoel Janssen <roel@gnu.org>2021-05-26 09:29:01 +0200
commitb1fee8a00318f4cf2cb3f854edc70f5c000ab71f (patch)
tree500947e3b1eecdad9b9711d02ac9b24a4d532313 /gnu/packages
parentb84ead8c045f7921131dc66ab85ee1db3113607a (diff)
downloadguix-b1fee8a00318f4cf2cb3f854edc70f5c000ab71f.tar.gz
gnu: Add r-spp.
* gnu/packages/bioinformatics.scm (r-spp): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9c77d66a35..bcc9f5bef2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8108,6 +8108,30 @@ sequence motif occurrences across a large set of sequences centred at a common
 reference point and sorted by a user defined feature.")
     (license license:gpl3+)))
 
+(define-public r-spp
+  (package
+    (name "r-spp")
+    (version "1.16.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "spp" version))
+              (sha256
+               (base32
+                "08zxxgyp0h6733b08jmml7k4rhfd3mi5dda3jrzid0s184y0z29w"))))
+    (build-system r-build-system)
+    (inputs
+     `(("zlib" ,zlib)))
+    (propagated-inputs
+     `(("r-bh" ,r-bh)
+       ("r-catools" ,r-catools)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rsamtools" ,r-rsamtools)))
+    (home-page "https://cran.r-project.org/web/packages/spp/")
+    (synopsis "ChIP-Seq processing pipeline")
+    (description "This package provides tools for analysis of ChIP-seq and
+other functional sequencing data.")
+    (license license:gpl2)))
+
 (define-public r-genomation
   (package
     (name "r-genomation")