summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-23 17:09:49 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-23 23:57:56 +0100
commitb596306cd4939fbb5106f35d2c1319c58106cc72 (patch)
treec9e0bbca0a6ac3af2d66e715cd247d03201b5b5b /gnu/packages
parent2a222b7a22e2dcd17ba24dcb84abb96d9ff4b715 (diff)
downloadguix-b596306cd4939fbb5106f35d2c1319c58106cc72.tar.gz
gnu: Add perl-net-dns-native.
* gnu/packages/perl.scm (perl-net-dns-native): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 7ff55546c6..47fff558fb 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5948,6 +5948,29 @@ cycle.  Functions called in the package itself will still be bound by their
 name, but they won't show up as methods on your class or instances.")
     (license (package-license perl))))
 
+(define-public perl-net-dns-native
+  (package
+    (name "perl-net-dns-native")
+    (version "0.15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/O/OL/OLEG/Net-DNS-Native-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "12bsv5jkic3q4arpzk6dda35didkn445v658j87rmi540dpnac85"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Net-DNS-Native/")
+    (synopsis "Non-blocking system DNS resolver")
+    (description
+     "This class provides several methods for host name resolution.  It is
+designed to be used with event loops.  Names are resolved by your system's
+native @code{getaddrinfo(3)} implementation, called in a separate thread to
+avoid blocking the entire application.  Threading overhead is limited by using
+system threads instead of Perl threads.")
+    (license perl-license)))
+
 (define-public perl-net-idn-encode
   (package
     (name "perl-net-idn-encode")