summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-20 05:26:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-21 02:03:22 +0200
commitdf12af98a86816e78f826b10a062bfe79de6c47a (patch)
tree956199a8bca398b2875c2a33a1ad7a709be41f12 /gnu/packages
parentfbde37884fe35f5caf2a0e33fc734d0ca40ad893 (diff)
downloadguix-df12af98a86816e78f826b10a062bfe79de6c47a.tar.gz
gnu: r-colorout: Don't use unstable tarball.
* gnu/packages/statistics.scm (r-colorout)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 8923481b6c..7b8622ebfc 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5736,12 +5736,13 @@ shaped points?  Now you can!")
     (version "1.2-2")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/jalvesaq/colorout/archive/"
-                           "v" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jalvesaq/colorout.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "1ylwxnaq5l6ldls44wij4i6080fv002wj33q63h8nqbp52fmkl67"))))
+        (base32 "1rsx69wjpa73c6x2hacvvvbzdzxn7wg06gizf97kasjdlb7azmp3"))))
     (build-system r-build-system)
     (home-page "https://github.com/jalvesaq/colorout")
     (synopsis "Colorize output in the R REPL")