summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-04 15:22:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-04 15:24:58 +0100
commit0e851b7675a9fb6f4cc8c918d388b45d2bc13d74 (patch)
treec581e254e300536bb2f75120c6b334fba4194093 /gnu/packages
parent99d872ae04d50917767972b300f88e0f9179bba7 (diff)
downloadguix-0e851b7675a9fb6f4cc8c918d388b45d2bc13d74.tar.gz
gnu: texlive-bin: Patch references to sed and awk.
* gnu/packages/tex.scm (texlive-bin)[arguments]: Patch texlive scripts in
'post-install phase to satisfy references to sed and awk.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 43aefd57e6..a959ba1371 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -498,6 +498,14 @@ files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
                                   source "/texlive-scripts/source/")
                                  scripts)
 
+               ;; Patch them.
+               (let ((dirs (map dirname (list (which "sed") (which "awk")))))
+                 (with-directory-excursion scripts
+                   (substitute* '("mktexpk" "mktexmf" "mktexlsr")
+                     (("^version=" m)
+                      (format #false "PATH=\"~{~a:~}$PATH\"; export PATH~%~a"
+                              dirs m)))))
+
                ;; Make sure that fmtutil can find its Perl modules.
                (substitute* (string-append scripts "/fmtutil.pl")
                  (("\\$TEXMFROOT/")