summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 22:04:23 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:37 -0500
commit2ad520866f44e8c441810dbcce7f60923ee1e37b (patch)
tree456cad5b166f078237caa590040f183865893bab /gnu/packages
parentfbac9b178ea9b7273b7fc8bf99db8ad786ba8669 (diff)
downloadguix-2ad520866f44e8c441810dbcce7f60923ee1e37b.tar.gz
gnu: Add python-zope-proxy.
* gnu/packages/python.scm (python-zope-proxy, python2-zope-proxy): New
  variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0be8e6f6e1..afba511c6c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6226,3 +6226,30 @@ Markup Language.")
 
 (define-public python2-zope-configuration
   (package-with-python2 python-zope-configuration))
+
+(define-public python-zope-proxy
+  (package
+    (name "python-zope-proxy")
+    (version "4.1.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://pypi.python.org/packages/source/z"
+                           "/zope.proxy/zope.proxy-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0pqwwmvm1prhwv1ziv9lp8iirz7xkwb6n2kyj36p2h0ppyyhjnm4"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-zope-interface" ,python-zope-interface)))
+    (home-page "http://pypi.python.org/pypi/zope.proxy")
+    (synopsis "Generic, transparent proxies")
+    (description "Zope.proxy provides generic, transparent proxies for Python.
+Proxies are special objects which serve as mostly-transparent wrappers around
+another object, intervening in the apparent behavior of the wrapped object
+only when necessary to apply the policy (e.g., access checking, location
+brokering, etc.) for which the proxy is responsible.")
+    (license zpl2.1)))
+
+(define-public python2-zope-proxy
+  (package-with-python2 python-zope-proxy))