summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-04 04:33:12 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-04 05:39:01 +0100
commit65fdb84d7ceff38b542ed129489fc14ce7612334 (patch)
tree851a0fd25828a685cd0bb685315f981efbf939aa /gnu/packages
parent99e4e234110f4d206102d3d3a4b0ffb10cb85b15 (diff)
downloadguix-65fdb84d7ceff38b542ed129489fc14ce7612334.tar.gz
gnu: direvent: Use G-expressions.
* gnu/packages/admin.scm (direvent)[source, arguments]:
Rewrite using G-expressions.  Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm43
1 files changed, 21 insertions, 22 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5181b3046c..48a65e649b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -76,6 +76,7 @@
   #:use-module (guix build-system trivial)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix gexp)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix utils)
@@ -2387,30 +2388,28 @@ features of ls(1), find(1), stat(1) and du(1).")
                (base32
                 "0m9vi01b1km0cpknflyzsjnknbava0s1n6393b2bpjwyvb6j5613"))
               (modules '((guix build utils)))
-              (snippet '(begin
-                          (substitute* "tests/testsuite"
-                            (("#![[:blank:]]?/bin/sh")
-                             "#!$SHELL"))
-                          #t))))
+              (snippet
+               #~(begin
+                   (substitute* "tests/testsuite"
+                     (("#![[:blank:]]?/bin/sh")
+                      "#!$SHELL"))))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'patch-/bin/sh
-           (lambda* (#:key inputs #:allow-other-keys)
-             ;; Use the right shell when executing the watcher and
-             ;; user-provided shell commands.
-             (let ((bash (assoc-ref inputs "bash")))
-               (substitute* '("src/direvent.c" "src/progman.c")
-                 (("\"/bin/sh\"")
-                  (string-append "\"" bash "/bin/sh\"")))
-
-               ;; Adjust the 'shell.at' test accordingly.
-               (substitute* "tests/testsuite"
-                 (("SHELL=/bin/sh")
-                  (string-append "SHELL=" bash "/bin/sh")))
-
-               #t))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'build 'patch-/bin/sh
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   ;; Use the right shell when executing the watcher and
+                   ;; user-provided shell commands.
+                   (let ((bash (assoc-ref inputs "bash")))
+                     (substitute* '("src/direvent.c" "src/progman.c")
+                       (("\"/bin/sh\"")
+                        (string-append "\"" bash "/bin/sh\"")))
+
+                     ;; Adjust the 'shell.at' test accordingly.
+                     (substitute* "tests/testsuite"
+                       (("SHELL=/bin/sh")
+                        (string-append "SHELL=" bash "/bin/sh")))))))))
     (home-page "https://www.gnu.org.ua/software/direvent/")
     (synopsis "Daemon to monitor directories for events such as file removal")
     (description