summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-03 14:55:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-03 14:59:16 +0100
commit98d93f97696b503f5e0e414295ddaf4013df1d56 (patch)
tree95d4812377500b6715c6d6da27785251e73a027c /gnu/packages
parentab6d56d01d62757caa66fe0a23e8864c9122f0e6 (diff)
downloadguix-98d93f97696b503f5e0e414295ddaf4013df1d56.tar.gz
gnu: Add r-anndata.
* gnu/packages/cran.scm (r-anndata): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bcfe9a2848..b9b1171496 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22513,6 +22513,29 @@ They are based on clustering, the statistical concept of data depth,
 statistical shape analysis and archetypal analysis.")
     (license license:gpl2+)))
 
+(define-public r-anndata
+  (package
+    (name "r-anndata")
+    (version "0.7.5.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "anndata" version))
+       (sha256
+        (base32 "115v7gdilayd18hd519vzkixp2s6rvvrd1inc1i6amn7d0spy8r1"))))
+    (properties `((upstream-name . "anndata")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-assertthat r-matrix r-r6 r-reticulate))
+    (native-inputs (list r-knitr))
+    (home-page "https://anndata.dynverse.org")
+    (synopsis "Anndata for R")
+    (description
+     "This package provides a reticulate wrapper for the Python package
+@code{anndata}.  It provides a scalable way of keeping track of data and
+learned annotations.  It is used to read from and write to the h5ad file
+format.")
+    (license license:expat)))
+
 (define-public r-adamethods
   (package
     (name "r-adamethods")