summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDomagoj Stolfa <domagoj.stolfa@gmail.com>2021-07-11 15:55:57 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-07-13 15:14:16 +0300
commitc2967eae4ee19f3c48825c613c98fe2d7e1383d8 (patch)
treeaf5fe5248ba67a93f3379081bf1e03aa9f7b4ca4 /gnu/packages
parenta2c766d73dd40301b32b09a1b5bb19fb1cc2f0a3 (diff)
downloadguix-c2967eae4ee19f3c48825c613c98fe2d7e1383d8.tar.gz
gnu: Add rust-colored-2.
* gnu/packages/crates-io.scm (rust-colored-2): New variable.
(rust-colored-1): Inherit from rust-colored-2.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2c4ac74eb6..71b28aab07 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -8624,10 +8624,10 @@ diagnostics easy and relatively painless for everyone!")
 colors.")
     (license license:expat)))
 
-(define-public rust-colored-1
+(define-public rust-colored-2
   (package
     (name "rust-colored")
-    (version "1.9.3")
+    (version "2.0.0")
     (source
       (origin
         (method url-fetch)
@@ -8636,7 +8636,7 @@ colors.")
          (string-append name "-" version ".tar.gz"))
         (sha256
          (base32
-          "0nbc1czs512h1k696y7glv1kjrb2b914zpxraic6q5fgv80wizzl"))))
+          "1gbcijscmznzy42rn213yp9ima7210zakgaqibgg1n441dsnyqdk"))))
     (build-system cargo-build-system)
     (arguments
      `(#:tests? #f
@@ -8660,6 +8660,21 @@ colors.")
      "The most simple way to add colors in your terminal.")
     (license license:mpl2.0)))
 
+(define-public rust-colored-1
+  (package
+    (inherit rust-colored-2)
+    (name "rust-colored")
+    (version "1.9.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "colored" version))
+        (file-name
+         (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "0nbc1czs512h1k696y7glv1kjrb2b914zpxraic6q5fgv80wizzl"))))))
+
 (define-public rust-colored-1.9.1
   (package
     (inherit rust-colored-1)