summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-05 17:02:23 +0200
committerMarius Bakke <marius@gnu.org>2022-09-07 17:36:42 +0200
commit1329b64db55f5a3d8735349e09be05157a062d63 (patch)
treed2d0ac3ece3d6f2ea1c9df60cb6912d75f438bac /gnu/packages
parent8d5637103fab0ce69e55d88bdc929f903ac58edd (diff)
downloadguix-1329b64db55f5a3d8735349e09be05157a062d63.tar.gz
gnu: python-jdcal: Update to 1.4.1.
* gnu/packages/python-xyz.scm (python-jdcal): Update to 1.4.1.
[arguments]: Use G-expression and respect TESTS? keyword.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d292f329b0..90fb380f88 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3549,20 +3549,22 @@ version numbers.")
 (define-public python-jdcal
   (package
     (name "python-jdcal")
-    (version "1.4")
+    (version "1.4.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "jdcal" version))
         (sha256
           (base32
-            "1ja6j2xq97bsl6rv09mhdx7n0xnrsfx0mj5xqza0mxghqmkm02pa"))))
+            "1j6g19jf21qprjsr8h0r7nsbss366gy8j9izq8cz53gbjvh74a27"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda _
-                      (invoke "pytest"))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "pytest" "-vv")))))))
     (native-inputs
      (list python-pytest))
     (home-page "https://github.com/phn/jdcal")