summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-05-21 19:19:31 -0500
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:12 +0200
commit21ca4719b3996b7c752f5e996e801d67c3bf2748 (patch)
tree8738e1301083a2c3e809559ab1d15709f1a6563f /gnu/packages
parent923aad065c66d660a16fe0f187f712d842c9a1a0 (diff)
downloadguix-21ca4719b3996b7c752f5e996e801d67c3bf2748.tar.gz
gnu: Add emacs-corfu-doc.
* gnu/packages/emacs-xyz.scm (emacs-corfu-doc): New variable.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 367e679c5c..343cc2186e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3142,6 +3142,29 @@ the point.  Corfu can be considered the minimalistic
 @code{completion-in-region} counterpart of the Vertico minibuffer UI.")
     (license license:gpl3+)))
 
+(define-public emacs-corfu-doc
+  (package
+    (name "emacs-corfu-doc")
+    (version "0.6.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/galeo/corfu-doc")
+             (commit "f9566cf13f6730a45b2f3c12e491a3fa2097e5d5")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "098yf29yv1b11p7kvdc7n4ra7f5vcmf6nlvhl85jgwqrsdz1795b"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-corfu))
+    (home-page "https://github.com/galeo/corfu-doc")
+    (synopsis "Documentation popup for Corfu")
+    (description
+     "The @code{corfu-doc} package provides a way to display a documentation
+popup for completion candidates when using @code{emacs-corfu}.  It can
+be regarded as @code{emacs-company-quickhelp} for @code{emacs-corfu}.")
+    (license license:gpl3+)))
+
 (define-public emacs-cape
   (package
     (name "emacs-cape")