summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-03-29 00:43:10 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-29 00:50:35 +0100
commit586d30caa2fb6372ab991f4284e92b19ebf15878 (patch)
tree21a9b29867a9c0c12676b74e251fe4716ab5cb78 /gnu/packages
parent339c1365fd090795154bf6086f0102d7c9079c95 (diff)
downloadguix-586d30caa2fb6372ab991f4284e92b19ebf15878.tar.gz
gnu: rust: Fix test setup.
* gnu/packages/rust.scm (rust-1.30)[arguments]<#:phases>
[disable-amd64-avx-test]: Replace.
(rust)[arguments]<#:phases>[disable-amd64-avx-test]: Replace.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/rust.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index bdb8d5fa2a..5151cacd42 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -877,7 +877,13 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
                    ;; these for now
                    (("fn include") "#[ignore]\nfn include")
                    (("fn exclude") "#[ignore]\nfn exclude"))
-                   #t)))))))))
+                   #t))
+             ;; The test has been moved elsewhere.
+             (replace 'disable-amd64-avx-test
+               (lambda _
+                 (substitute* "src/test/ui/run-pass/issues/issue-44056.rs"
+                  (("only-x86_64") "ignore-test"))
+                  #t)))))))))
 
 (define-public rust
   (let ((base-rust
@@ -908,6 +914,12 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
                      ((" Command::new\\(\"echo\"\\)")
                       (string-append "\nCommand::new(\"" coreutils "/bin/echo\")\n")))
                    #t)))
+              ;; The test has been moved elsewhere.
+              (replace 'disable-amd64-avx-test
+                (lambda _
+                  (substitute* "src/test/ui/issues/issue-44056.rs"
+                   (("only-x86_64") "ignore-test"))
+                  #t))
              (add-after 'patch-tests 'patch-process-docs-rev-cmd
                (lambda* _
                  ;; Disable some doc tests which depend on the "rev" command