summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-07-02 13:58:02 -0500
committerEric Bavier <bavier@member.fsf.org>2014-07-02 13:58:02 -0500
commit59bad04fe4dd3f030ac1e11530799a96cdc121e8 (patch)
treed984408411e661ab7d888b4580849a395111a775 /gnu/packages
parentf1fc45a9fd168f3b44f03112815bda83d2c6f3ed (diff)
downloadguix-59bad04fe4dd3f030ac1e11530799a96cdc121e8.tar.gz
gnu: glib: Upgrade to 2.40.0.
* gnu/packages/glib.scm (glib)[source]: Upgrade to 2.40.0.  Adjust
  patch list.
* gnu/packages/patches/glib-tests-newnet.patch: Remove.
* gnu/packages/patches/glib-tests-desktop.patch: Adjust for 2.40.0.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/glib.scm9
-rw-r--r--gnu/packages/patches/glib-tests-desktop.patch47
-rw-r--r--gnu/packages/patches/glib-tests-newnet.patch30
3 files changed, 30 insertions, 56 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 59efc6eaf5..c3b0b39f10 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -106,18 +106,17 @@ shared NFS home directories.")
 (define glib
   (package
    (name "glib")
-   (version "2.39.1")
+   (version "2.40.0")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnome/sources/"
                                 name "/" (string-take version 4) "/"
                                 name "-" version ".tar.xz"))
             (sha256
-             (base32 "0lqi6z47068vgh91fm59jn0kq969wf3g2q8k4m33jsb0amprg36h"))
+             (base32 "1d98mbqjmc34s8095lkw1j1bwvnnkw9581yfvjaikjvfjsaz29qd"))
             (patches (list (search-patch "glib-tests-homedir.patch")
                            (search-patch "glib-tests-desktop.patch")
-                           (search-patch "glib-tests-prlimit.patch")
-                           (search-patch "glib-tests-newnet.patch")))))
+                           (search-patch "glib-tests-prlimit.patch")))))
    (build-system gnu-build-system)
    (outputs '("out"           ; everything
               "bin"           ; glib-mkenums, gtester, etc.; depends on Python
@@ -128,7 +127,7 @@ shared NFS home directories.")
       ("zlib" ,zlib)
       ("tzdata" ,tzdata)))     ; for tests/gdatetime.c
    (native-inputs
-     `(("gettext" ,gnu-gettext)
+    `(("gettext" ,gnu-gettext)
       ("dbus" ,dbus)                              ; for GDBus tests
       ("pkg-config" ,pkg-config)
       ("python" ,python-wrapper)
diff --git a/gnu/packages/patches/glib-tests-desktop.patch b/gnu/packages/patches/glib-tests-desktop.patch
index efa877c59e..61f48607f7 100644
--- a/gnu/packages/patches/glib-tests-desktop.patch
+++ b/gnu/packages/patches/glib-tests-desktop.patch
@@ -21,10 +21,10 @@ database, the `update-desktop-database' program, which we don't provide.
  
    return g_test_run ();
 
---- glib-2.34.3/gio/tests/contenttype.c	2013-01-16 21:22:29.000000000 +0100
-+++ glib-2.34.3/gio/tests/contenttype.c	2013-01-16 21:22:33.000000000 +0100
-@@ -207,13 +207,6 @@ main (int argc, char *argv[])
- 
+--- glib-2.40.0/gio/tests/contenttype.c	2013-01-16 21:22:29.000000000 +0100
++++ glib-2.40.0/gio/tests/contenttype.c	2013-01-16 21:22:33.000000000 +0100
+@@ -207,15 +207,6 @@ main (int argc, char *argv[])
+ {
    g_test_init (&argc, &argv, NULL);
  
 -  g_test_add_func ("/contenttype/guess", test_guess);
@@ -34,18 +34,21 @@ database, the `update-desktop-database' program, which we don't provide.
 -  g_test_add_func ("/contenttype/executable", test_executable);
 -  g_test_add_func ("/contenttype/description", test_description);
 -  g_test_add_func ("/contenttype/icon", test_icon);
+-  g_test_add_func ("/contenttype/symbolic-icon", test_symbolic_icon);
+-  g_test_add_func ("/contenttype/tree", test_tree);
  
    return g_test_run ();
  }
 
 
---- glib-2.39.1/gio/tests/desktop-app-info.c	2013-06-07 23:46:28.000000000 +0200
-+++ glib-2.39.1/gio/tests/desktop-app-info.c	2013-06-07 23:46:32.000000000 +0200
-@@ -699,6 +699,7 @@ main (int   argc,
+--- glib-2.40.0/gio/tests/desktop-app-info.c	2014-03-19 22:50:45.000000000 -0500
++++ glib-2.40.0/gio/tests/desktop-app-info.c	2014-06-30 14:27:52.543358331 -0500
+@@ -708,6 +708,8 @@
    g_setenv ("XDG_DATA_HOME", basedir, TRUE);
    cleanup_subdirs (basedir);
  
-+  return 0;
++  result = g_test_run ();
++  return result;
    g_test_add_func ("/desktop-app-info/delete", test_delete);
    g_test_add_func ("/desktop-app-info/default", test_default);
    g_test_add_func ("/desktop-app-info/fallback", test_fallback);
@@ -81,31 +84,33 @@ because that script depends on python-gobject.
 
 The test below depends on the availability /etc/passwd to dbus-daemon.
 
---- glib-2.38.0.orig/gio/tests/gdbus-auth.c     2013-05-07 20:26:07.000000000 +0200
-+++ glib-2.38.0/gio/tests/gdbus-auth.c  2013-09-30 19:42:27.000000000 +0200
-@@ -284,6 +284,7 @@
+--- glib-2.40.0/gio/tests/gdbus-auth.c	2014-02-03 11:40:41.000000000 -0600
++++ glib-2.40.0/gio/tests/gdbus-auth.c	2014-06-30 15:08:43.719421893 -0500
+@@ -286,6 +286,8 @@
  {
    gint ret;
-
-+  return 0;
+ 
++  g_test_init (&argc, &argv, NULL);
++  return g_test_run();
    setlocale (LC_ALL, "C");
-
+ 
    temp_dbus_keyrings_setup ();
 
 
 The test dbus-appinfo is dropped as it hangs indefinitely since 2.37.5, see
    https://launchpad.net/ubuntu/+source/glib2.0/2.37.5-1ubuntu1
 
---- glib-2.38.0.orig/gio/tests/dbus-appinfo.c   2013-09-05 12:43:41.000000000 +0200
-+++ glib-2.38.0/gio/tests/dbus-appinfo.c        2013-09-30 21:57:21.000000000 +0200
-@@ -278,6 +278,7 @@
- int
- main (int argc, char **argv)
+--- glib-2.40.0/gio/tests/dbus-appinfo.c	2014-02-03 11:40:41.000000000 -0600
++++ glib-2.40.0/gio/tests/dbus-appinfo.c	2014-06-30 14:44:08.215383632 -0500
+@@ -278,7 +278,7 @@
  {
-+  return 0;
    g_test_init (&argc, &argv, NULL);
  
-   session_bus_up ();
+-  g_test_add_func ("/appinfo/dbusappinfo", test_dbus_appinfo);
++  return g_test_run();
+ 
+   return session_bus_run ();
+ }
 
 
 The test below fails for unknown reasons (!).
diff --git a/gnu/packages/patches/glib-tests-newnet.patch b/gnu/packages/patches/glib-tests-newnet.patch
deleted file mode 100644
index 324b8ae68f..0000000000
--- a/gnu/packages/patches/glib-tests-newnet.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Since guix-daemon runs in a separate networking name space, the only
-interface available is "lo".  However its index is incremented by one
-at each build, so it can end up being greater than 255, leading to an
-assertion failure in 'find_ifname_and_index'.
-
-Work around that by directly querying the index of "lo".
-
---- glib-2.38.0/gio/tests/network-address.c	2013-09-17 20:47:14.000000000 +0200
-+++ glib-2.38.0/gio/tests/network-address.c	2013-10-16 21:52:42.000000000 +0200
-@@ -117,7 +117,7 @@ test_parse_host (gconstpointer d)
- #define SCOPE_ID_TEST_PORT 99
- 
- #ifdef HAVE_IF_INDEXTONAME
--static char SCOPE_ID_TEST_IFNAME[IF_NAMESIZE];
-+static char SCOPE_ID_TEST_IFNAME[] = "lo";
- static int SCOPE_ID_TEST_INDEX;
- #else
- #define SCOPE_ID_TEST_IFNAME "1"
-@@ -131,11 +131,7 @@ find_ifname_and_index (void)
-     return;
- 
- #ifdef HAVE_IF_INDEXTONAME
--  for (SCOPE_ID_TEST_INDEX = 1; SCOPE_ID_TEST_INDEX < 255; SCOPE_ID_TEST_INDEX++) {
--    if (if_indextoname (SCOPE_ID_TEST_INDEX, SCOPE_ID_TEST_IFNAME))
--      break;
--  }
--  g_assert_cmpstr (SCOPE_ID_TEST_IFNAME, !=, "");
-+  SCOPE_ID_TEST_INDEX = if_nametoindex (SCOPE_ID_TEST_IFNAME);
- #endif
- }