summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2022-08-03 20:37:42 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-08-25 13:45:46 +0200
commit6f678b847a9cccfa2e028c6f1d3286a8b8f23350 (patch)
treefe2b6e19700c208003662f6d21ee99bd3855ff0e /gnu/packages
parent80baa8f87aa69151dffe04fb432a37c91d4dd242 (diff)
downloadguix-6f678b847a9cccfa2e028c6f1d3286a8b8f23350.tar.gz
gnu: Add emacs-buffer-env.
* gnu/packages/emacs-xyz.scm (emacs-buffer-env): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b7460eb085..96635957db 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29557,6 +29557,27 @@ text, such a marking style might be used to show externally included text or
 example code.")
     (license license:gpl3+)))
 
+(define-public emacs-buffer-env
+  (package
+    (name "emacs-buffer-env")
+    (version "0.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://elpa.gnu.org/packages/buffer-env-"
+                                  version ".tar"))
+              (sha256
+               (base32
+                "0y8ik87dqldhn6q631zp2ln9z5byqgm9icrvr4xrdx6g8mr9c56z"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-compat))
+    (home-page "https://github.com/astoff/buffer-env")
+    (synopsis "Create buffer-local process environments")
+    (description "This package creates buffer-local environments using scripts
+similar to Direnv.  This allows Emacs to call the correct version of external
+programs such as linters, compilers, and language servers on a per-project
+basis.")
+    (license license:gpl3+)))
+
 (define-public emacs-buffer-move
   (package
     (name "emacs-buffer-move")