summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAdam Kandur <rndd@tuta.io>2021-02-15 13:48:44 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-15 13:48:44 +0100
commit71533bb49da6fc058f6a5e8142cbf612380813ef (patch)
tree725d5a9d06b5364457067e89007aa7b6b7e42a02 /gnu/packages
parent2b5a81dfd3f7a633f4137d31060d0fa82c5e89f6 (diff)
downloadguix-71533bb49da6fc058f6a5e8142cbf612380813ef.tar.gz
gnu: Add emacs-theme-sorcery.
* gnu/packages/emacs-xyz.scm (emacs-theme-sorcery): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3c1d0fc981..0ac391985b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -805,6 +805,30 @@ theme and apply them to the rest of Linux with Pywal.  Pywal only applies your
 theme to the current session.")
       (license license:gpl3+))))
 
+(define-public emacs-theme-sorcery
+  (let ((revision "0")
+        (commit "5a1c4445b9e6e09589a299a9962a6973272a0c2f"))
+    (package
+      (name "emacs-theme-sorcery")
+      (version "1.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mtreca/emacs-theme-sorcery")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1b858049n6nw4qf60fmszjrhl80x7ssh32f7glj722kwy7404kdh"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-autothemer" ,emacs-autothemer)))
+      (home-page "https://github.com/mtreca/emacs-theme-sorcery")
+      (synopsis "Dark and low-contrast Emacs theme")
+      (description "Sorcery is a dark and low-contrast Emacs theme inspired by
+Apprentice and Sourcerer.")
+      (license license:gpl3+))))
+
 (define-public emacs-treepy
   (package
     (name "emacs-treepy")