summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-06 11:50:14 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-09 22:57:44 +0100
commit99d4c455e364c7771dec069727ef9e9d3faa31b0 (patch)
tree651115b5b5f79c6299dc3e87f0a8b5878b92a618 /gnu/packages
parent3bfb78dc3bb29c074189cafbd9056cb509322a16 (diff)
downloadguix-99d4c455e364c7771dec069727ef9e9d3faa31b0.tar.gz
gnu: Add libdv.
* gnu/packages/video.scm (libdv): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/video.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b825ddba91..aa06ebe021 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -102,6 +102,29 @@ television and DVD.  It is also known as AC-3.")
 streams.")
     (license gpl2+)))
 
+(define-public libdv
+  (package
+    (name "libdv")
+    (version "1.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://sourceforge/libdv/libdv-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1fl96f2xh2slkv1i1ix7kqk576a0ak1d33cylm0mbhm96d0761d3"))))
+    (build-system gnu-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("libxv" ,libxv)))
+    (home-page "http://libdv.sourceforge.net/")
+    (synopsis "DV video (IEC 61834 and SMPTE 314M) codec")
+    (description "The Quasar DV codec (libdv) is a software codec for DV
+video, the encoding format used by most digital camcorders, typically those
+that support the IEEE 1394 (a.k.a. FireWire or i.Link) interface.  Libdv was
+developed according to the official standards for DV video: IEC 61834 and
+SMPTE 314M.")
+    (license lgpl2.1+)))
+
 (define-public ffmpeg
   (package
     (name "ffmpeg")