summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:44 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:32 +0200
commita094dcc1a3e1e8f6a4851b7588c42625dee1cd75 (patch)
tree202520a1def93a7c24f7dfc16823c1709318816f /gnu/packages
parent791d36a8f7e6342ffdea210c013a21510690482d (diff)
downloadguix-a094dcc1a3e1e8f6a4851b7588c42625dee1cd75.tar.gz
gnu: Add trytond-sale-shipment-cost.
* gnu/packages/tryton.scm (trytond-sale-shipment-cost): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tryton.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index ffd0fcd6f6..4b09e8227f 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3422,6 +3422,36 @@ price are kept synchronized with the quantity and unit price.  The secondary
 unit is defined on the product with its factor against the sale unit.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-shipment-cost
+  (package
+    (name "trytond-sale-shipment-cost")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_shipment_cost" version))
+       (sha256
+        (base32 "1h1qhp90f8mzx2px48fa8xsgwhbf2gkg8q94vghy696a3hh1xzxb"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_shipment_cost"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-sale-promotion" ,trytond-sale-promotion)
+       ("trytond-stock-shipment-cost" ,trytond-stock-shipment-cost)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-carrier" ,trytond-carrier)
+       ("trytond-currency" ,trytond-currency)
+       ("trytond-product" ,trytond-product)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-shipment-cost")
+    (synopsis "Tryton module for sale shipment cost")
+    (description "The @emph{Sale Shipment Cost} Tryton module adds shipment
+cost for sale.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")