summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:36 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:31 +0200
commitba41f4ef6f522e3c2ffd8a3f921ff890a116ed35 (patch)
tree9555730c6fbf239aa7ea8b4c6167bb5fda72de26 /gnu/packages
parent9c5930fe9714c1b076e7bc78b612a29e35bc4b9d (diff)
downloadguix-ba41f4ef6f522e3c2ffd8a3f921ff890a116ed35.tar.gz
gnu: Add trytond-purchase-shipment-cost.
* gnu/packages/tryton.scm (trytond-purchase-shipment-cost): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tryton.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4bef8f4267..0e46b01ae0 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2938,6 +2938,37 @@ and unit price.  The secondary unit is defined on the product supplier or on
 the product with its factor against the purchase unit.")
     (license license:gpl3+)))
 
+(define-public trytond-purchase-shipment-cost
+  (package
+    (name "trytond-purchase-shipment-cost")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_purchase_shipment_cost" version))
+       (sha256
+        (base32 "0n54mkw8fbhyxn8sxrkn97bkx2c1j7bngsc7isc3md5c3kyi50nf"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "purchase_shipment_cost"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-account-invoice-stock" ,trytond-account-invoice-stock)
+       ("trytond-account-stock-anglo-saxon" ,trytond-account-stock-anglo-saxon)
+       ("trytond-account-stock-continental" ,trytond-account-stock-continental)
+       ("trytond-purchase" ,trytond-purchase)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-carrier" ,trytond-carrier)
+       ("trytond-currency" ,trytond-currency)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-purchase-shipment-cost")
+    (synopsis "Tryton module for purchase shipment costs")
+    (description "The @emph{Purchase Shipment Cost} Tryton module adds
+shipment costs to Supplier Shipment.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")