summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2021-11-28 21:15:17 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-28 21:31:08 +0100
commitbf90403f42556bd1b80773723a3c04b404641d08 (patch)
tree47e61f5e80153c68ec7dee63cc91b2caa917e87a /gnu/packages
parent25cb5bad5e2475a49e20a2da888652e0bd322530 (diff)
downloadguix-bf90403f42556bd1b80773723a3c04b404641d08.tar.gz
gnu: python-trezor-agent: Update to 0.14.2.
* gnu/packages/finance.scm (python-trezor-agent): Update to 0.14.2.
[propagated-inputs]: Add python-pynacl, python-hidapi.  Remove python-ed25519.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/finance.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index f4978a444b..334a3e7a90 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -833,9 +833,11 @@ the Monero GUI client.")
     (license license:bsd-3)))
 
 (define-public python-trezor-agent
+  ;; It is called 'libagent' in pypi; i.e. this is the library as opposed to
+  ;; the toplevel app called trezor-agent.
   (package
     (name "python-trezor-agent")
-    (version "0.13.1")
+    (version "0.14.2")
     (source
      (origin
        (method git-fetch)
@@ -844,7 +846,7 @@ the Monero GUI client.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0q99vbfd3h85s8rnjipnmldixabqmmlk5w9karv6f0rhyi54f4zv"))
+        (base32 "0nl44ldfw9s2v3p7g5bldfw3ds2hz9r28j42bpnp8bj0v5na3ivk"))
        (patches (search-patches "python-trezor-agent-fix-argv0.patch"))))
     (build-system python-build-system)
     (arguments
@@ -868,9 +870,10 @@ the Monero GUI client.")
        ("python-daemon" ,python-daemon)
        ("python-docutils" ,python-docutils)
        ("python-ecdsa" ,python-ecdsa)
-       ("python-ed25519" ,python-ed25519)
+       ("python-hidapi" ,python-hidapi)
        ("python-mnemonic" ,python-mnemonic)
        ("python-pymsgbox" ,python-pymsgbox)
+       ("python-pynacl" ,python-pynacl)
        ("python-semver" ,python-semver)
        ("python-unidecode" ,python-unidecode)
        ("python-wheel" ,python-wheel)))