summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-09-04 11:29:34 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-09-22 13:41:49 +0200
commitcd5145875e2741e704611753300f43c3caabdc02 (patch)
treeba7550d048f801d00cf7d433c6462687c5d7a7bf /gnu/packages
parentf4278d1f77955c0aa34c21021506927ddf5d6eca (diff)
downloadguix-cd5145875e2741e704611753300f43c3caabdc02.tar.gz
gnu: allegro: Update to 5.2.7.0.
* gnu/packages/game-development.scm (allegro): Update to 5.2.7.0.
[inputs]: Use gtk+ instead of gtk+-2.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/game-development.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 40807450ea..bf7cbdf9c1 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -830,7 +830,7 @@ etc.")
 (define-public allegro
   (package
     (name "allegro")
-    (version "5.2.5.0")
+    (version "5.2.7.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/liballeg/allegro5/releases"
@@ -838,7 +838,7 @@ etc.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "06dpkfnac8w3pq36834nn2iij3ajz6prladqd0w92lq39aiqv5jr"))))
+                "034pmbmbq6jagpp4lhnyjqmf8gcz5fx74d9rknrm7d4wv4cv7qy1"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f))          ; there are no tests
     (inputs
@@ -846,7 +846,7 @@ etc.")
      `(("flac" ,flac)
        ("freetype" ,freetype)
        ("glu" ,glu)
-       ("gtk" ,gtk+-2)
+       ("gtk" ,gtk+)
        ("libjpeg" ,libjpeg-turbo)
        ("libpng" ,libpng)
        ("libtheora" ,libtheora)