summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-08 23:07:36 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:39 -0400
commit05cbfea0b294722da0b95736cc91cf771a3a9f2d (patch)
treeaeacac9575bc483b354ee1b16455035d54d7c7b4 /gnu/packages
parent51f0c0af2de75292985b943cb808f176dd618585 (diff)
downloadguix-05cbfea0b294722da0b95736cc91cf771a3a9f2d.tar.gz
gnu: Add python-sfdlib.
* gnu/packages/fontutils.scm (python-sfdlib): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/fontutils.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 74b10232b8..444d1635cb 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -632,6 +632,28 @@ suite of the @code{psautohint} package.")
 can be used to hint PostScript fonts.  A Python wrapper is also included.")
     (license license:asl2.0)))
 
+(define-public python-sfdlib
+  (package
+    (name "python-sfdlib")
+    (version "1.2.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/aliftype/sfdLib")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1q61km32i1h3cmn8nazcgsbzpm8q2nxp3kq3glqgfgvlxr1s3brm"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-ufolib2))
+    (home-page "https://github.com/aliftype/sfdLib")
+    (synopsis "Simple SFD to UFO converter")
+    (description "This package provides the @command{sfd2ufo} command, a
+converter from FontForge’s @acronym{SFD, Spline Font Database} fonts to
+@acronym{UFO, Unified Font Object} fonts.")
+    (license license:bsd-3)))
+
 (define-public python-skia-pathops
   (package
     (name "python-skia-pathops")