summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-06 21:37:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-06 21:39:24 +0100
commit0c836f58cf8c63c2a7e3c4c05745665f1f1afb2f (patch)
treeeb808a666ef0cea7fb697402a8b2737913a5751b /gnu/packages
parent75f021f4a66e49087d96f63fe61565fcd06c889e (diff)
downloadguix-0c836f58cf8c63c2a7e3c4c05745665f1f1afb2f.tar.gz
gnu: Add r-egg.
* gnu/packages/cran.scm (r-egg): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 642672bb8d..8b72c1c51c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4683,6 +4683,33 @@ ordered factor data types.")
 exponentiation.")
     (license license:gpl2)))
 
+(define-public r-egg
+  (package
+    (name "r-egg")
+    (version "0.4.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "egg" version))
+       (sha256
+        (base32
+         "1fy7srpiavfn8kyrr1m84an7acgwi6ydzrg71m3b0vk7y9ybmj0m"))))
+    (properties `((upstream-name . "egg")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-gridextra" ,r-gridextra)
+       ("r-gtable" ,r-gtable)))
+    (home-page "https://cran.r-project.org/web/packages/egg")
+    (synopsis "Extensions for ggplot2")
+    (description
+     "This package provides miscellaneous functions to help customize ggplot2
+objects.  High-level functions are provided to post-process ggplot2 layouts
+and allow alignment between plot panels, as well as setting panel sizes to
+fixed values.  Other functions include a custom @code{geom}, and helper
+functions to enforce symmetric scales or add tags to facetted plots.")
+    (license license:gpl3)))
+
 (define-public r-heatmaply
   (package
     (name "r-heatmaply")