summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-06 15:44:12 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:36 -0400
commit0f8bb67dbb6d21dc56d8237d35fefeee8a3e6dc4 (patch)
tree5bbdd4c6334294b60d52f0f79b7ba22ebc12fed0 /gnu/packages
parentf2be0c5b2b19a4c867906f4ae1b4393d92cc4b08 (diff)
downloadguix-0f8bb67dbb6d21dc56d8237d35fefeee8a3e6dc4.tar.gz
gnu: python-pytest-cov: Update to 3.0.0.
This restores the package compatibility with python-pytest-xdist.

* gnu/packages/check.scm (python-pytest-cov): Update to 3.0.0.
(python2-pytest-cov): Delete package.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c67a6f2675..b7a5a9bd46 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1150,13 +1150,13 @@ following improvements:
 (define-public python-pytest-cov
   (package
     (name "python-pytest-cov")
-    (version "2.8.1")
+    (version "3.0.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "pytest-cov" version))
         (sha256
-         (base32 "0avzlk9p4nc44k7lpx9109dybq71xqnggxb9f4hp0l64pbc44ryc"))))
+         (base32 "0w6lfv8gc1lxmnvsz7mq5z9shxac5zz6s9mwrai108kxc6qzbw77"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -1178,9 +1178,6 @@ distributed testing in both @code{load} and @code{each} modes.  It also
 supports coverage of subprocesses.")
   (license license:expat)))
 
-(define-public python2-pytest-cov
-  (package-with-python2 python-pytest-cov))
-
 (define-public python-pytest-httpserver
   (package
     (name "python-pytest-httpserver")