summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-06-26 13:39:02 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-06-26 13:39:02 +0200
commit167fec29f509fbb2904ecb7226d5cdf1e490f5a5 (patch)
tree6973e0971fa8f4ca36855731b0ed202f9b058d7b /gnu/packages
parent63015205d82a2ab0c1b79462f96ca0a03543c3c5 (diff)
downloadguix-167fec29f509fbb2904ecb7226d5cdf1e490f5a5.tar.gz
gnu: Add sbcl-cl-reexport.
* gnu/packages/lisp.scm (sbcl-cl-reexport): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 62e9a35317..46c670b9ce 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -5933,3 +5933,31 @@ floating point values to IEEE 754 binary representation.")
 Closure is a reference to the web browser it was originally written for.")
       ;; TODO: License?
       (license #f))))
+
+(define-public sbcl-cl-reexport
+  (let ((commit "312f3661bbe187b5f28536cd7ec2956e91366c3b")
+        (revision "1"))
+    (package
+      (name "sbcl-cl-reexport")
+      (build-system asdf-build-system/sbcl)
+      (version (git-version "0.1" revision commit))
+      (home-page "https://github.com/takagi/cl-reexport")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url home-page)
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1cwpn1m3wrl0fl9plznn7p464db646gnfc8zkyk97dyxski2aq0x"))))
+      (inputs
+       `(("alexandria" ,sbcl-alexandria)))
+      (arguments
+       ;; TODO: Tests fail because cl-test-more is missing, but I can't find it online.
+       `(#:tests? #f))
+      (synopsis "HTTP cookie manager for Common Lisp")
+      (description "cl-cookie is a Common Lisp library featuring parsing of
+cookie headers, cookie creation, cookie jar creation and more.")
+      (license license:llgpl))))