summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:10:02 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:16 +0300
commit192a9a20f0a1c91a5ba8f7791297ce21b99f74f2 (patch)
treeb646807947d200fdc4c6bccf5706fada3a887fc0 /gnu/packages
parentbf8300de402d231d70a26a2f70bab72fb72108b0 (diff)
downloadguix-192a9a20f0a1c91a5ba8f7791297ce21b99f74f2.tar.gz
gnu: Add emacs-default-text-scale.
* gnu/packages/emacs.scm (emacs-default-text-scale): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9f9c479f4a..0945bf5c1a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9686,3 +9686,26 @@ standard key bindings and are all prefixed with rsw-elisp-.  They work the
 same way as the old commands when called non-interactively; only the
 interactive behavior should be different.")
     (license license:gpl3+)))
+
+(define-public emacs-default-text-scale
+  (let ((commit "968e985e219235f3e744d6d967e592acbaf6e0a8")
+        (revision "1"))
+    (package
+      (name "emacs-default-text-scale")
+      (version (string-append "0.1" "-" revision "."
+                              (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/purcell/default-text-scale")
+                      (commit commit)))
+                (file-name (string-append name "-" version "-checkout"))
+                (sha256
+                 (base32
+                  "0zds01c3q5yny6ab1fxfkzzgn1kgl3q23lxxap905f4qd70v922h"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/purcell/default-text-scale")
+      (synopsis "Adjust the font size in all Emacs frames")
+      (description "This package provides commands for increasing or
+decreasing the default font size in all GUI Emacs frames.")
+      (license license:gpl3+))))