summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-02-09 20:48:32 +0300
committerMarius Bakke <mbakke@fastmail.com>2017-02-09 22:54:58 +0100
commit1a917fc9de503d0d8b436c5c1467a34d29427178 (patch)
tree121749fdc13f5b5b8ce7c7ed91cfebf208c67ebc /gnu/packages
parentc09fbf20584c64e2c0c7061c4ff571a624354d8b (diff)
downloadguix-1a917fc9de503d0d8b436c5c1467a34d29427178.tar.gz
gnu: Add python-rst2ansi.
* gnu/packages/python.scm (python-rst2ansi): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5b4d2b09cf..a8bf99b8fe 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -35,6 +35,7 @@
 ;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
+;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -12536,3 +12537,24 @@ console.")
 This implementation is slow (hence the project name) but still useful when
 faster ones are not available.")
     (license license:asl2.0)))
+
+(define-public python-rst2ansi
+  (package
+    (name "python-rst2ansi")
+    (version "0.1.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "rst2ansi" version))
+       (sha256
+        (base32
+         "0vzy6gd60l79ff750scl0sz48r1laalkl6md6dwzah4dcadgn5qv"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-docutils" ,python-docutils)))
+    (home-page "https://github.com/Snaipe/python-rst-to-ansi")
+    (synopsis "Convert RST to ANSI-decorated console output")
+    (description
+     "Python module dedicated to rendering RST (reStructuredText) documents
+to ansi-escaped strings suitable for display in a terminal.")
+    (license license:expat)))