summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-15 22:22:09 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-15 22:24:35 +0200
commit1c9403f6a6f5d544cda63c6cb81446c63f72321c (patch)
treed2ff420ca654d5acff7e84e8ac30dfa96d35a28a /gnu/packages
parentfbfaafae27893f74f47188ecd0bce54df38981bd (diff)
downloadguix-1c9403f6a6f5d544cda63c6cb81446c63f72321c.tar.gz
gnu: kicad: Re-use common fields in add-ons.
* gnu/packages/engineering.scm (kicad-i18n, kicad-symbols): Re-use
kicad's VERSION and HOME-PAGE.
(kicad-symbols, kicad-footprints, kicad-packages3d, kicad-templates):
Re-use kicad's VERSION.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/engineering.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index fce76a7189..aec692174a 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -890,7 +890,7 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
 (define kicad-i18n
   (package
     (name "kicad-i18n")
-    (version "5.1.6")
+    (version (package-version kicad))
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -908,7 +908,7 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
          (delete 'check))))
     (native-inputs
      `(("gettext" ,gettext-minimal)))
-    (home-page "https://kicad-pcb.org/")
+    (home-page (package-home-page kicad))
     (synopsis "KiCad GUI translations")
     (description "This package contains the po files that are used for the GUI
 translations for KiCad.")
@@ -920,7 +920,7 @@ translations for KiCad.")
 (define-public kicad-symbols
   (package
     (name "kicad-symbols")
-    (version "5.1.6")
+    (version (package-version kicad))
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -933,7 +933,7 @@ translations for KiCad.")
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f))                    ; no tests exist
-    (home-page "https://kicad-pcb.org/")
+    (home-page (package-home-page kicad))
     (synopsis "Official KiCad schematic symbol libraries")
     (description "This package contains the official KiCad schematic symbol
 libraries.")
@@ -949,7 +949,7 @@ libraries.")
   (package
     (inherit kicad-symbols)
     (name "kicad-footprints")
-    (version "5.1.6")
+    (version (package-version kicad))
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -966,7 +966,7 @@ libraries.")
   (package
     (inherit kicad-symbols)
     (name "kicad-packages3d")
-    (version "5.1.6")
+    (version (package-version kicad))
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -983,7 +983,7 @@ libraries.")
   (package
     (inherit kicad-symbols)
     (name "kicad-templates")
-    (version "5.1.6")
+    (version (package-version kicad))
     (source (origin
               (method git-fetch)
               (uri (git-reference