summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-16 10:35:54 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:42 +0530
commit2a93f5a43c211993ce6ba3fef129649468c3fc39 (patch)
tree3e257b9e67f5b70fd1ebe7cd57de4927bccee917 /gnu/packages
parent1231ce9a0735f3ebb6456de97dc96a5cabcc9ca4 (diff)
downloadguix-2a93f5a43c211993ce6ba3fef129649468c3fc39.tar.gz
gnu: Add rust-blobby-0.3.
* gnu/packages/crates-io.scm (rust-blobby-0.3): New variable.
(rust-blobby-0.1): Inherit from rust-blobby-0.3.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm31
1 files changed, 25 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9d22e69c52..5430755ad0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1896,8 +1896,32 @@ BLAKE2bp hash functions.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-blobby-0.3
+  (package
+    (name "rust-blobby")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "blobby" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1s2f3a7lx5rd26554d9940basff7qpyf1y8gkc309cgc8csmalpw"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-development-inputs
+       (("rust-hex" ,rust-hex-0.3))))
+    (home-page "https://github.com/RustCrypto/utils")
+    (synopsis "Iterator over simple binary blob storage")
+    (description "This package provides an iterator over simple binary blob
+storage.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-blobby-0.1
   (package
+    (inherit rust-blobby-0.3)
     (name "rust-blobby")
     (version "0.1.2")
     (source
@@ -1916,12 +1940,7 @@ BLAKE2bp hash functions.")
        (("rust-byteorder" ,rust-byteorder-1))
        #:cargo-development-inputs
        (("rust-byteorder" ,rust-byteorder-1)
-        ("rust-hex" ,rust-hex-0.3))))
-    (home-page "https://github.com/RustCrypto/utils")
-    (synopsis "Iterator over simple binary blob storage")
-    (description
-     "Iterator over simple binary blob storage.")
-    (license (list license:asl2.0 license:expat))))
+        ("rust-hex" ,rust-hex-0.3))))))
 
 (define-public rust-block-0.1
   (package