summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-18 12:43:24 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-18 12:46:12 +0200
commit3963211668a2b5626805530568b88a9a4eb9e3f1 (patch)
tree9c7148da3269273f961a204463a6e7bd5209a9b2 /gnu/packages
parent048934c3b6afec494e3258f0a57a3031072022b2 (diff)
downloadguix-3963211668a2b5626805530568b88a9a4eb9e3f1.tar.gz
gnu: gupnp: Fix build.
* gnu/packages/gnome.scm (gupnp)[arguments]<#:phases>: Add a 'pre-check phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 53455a3518..6c817ec2e3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1329,6 +1329,13 @@ a debugging tool, @command{gssdp-device-sniffer}.")
              (base32
               "1ld7mrpdv9cszmfzh7i19qx4li25j3fr7x1jp38l8phzlmz3187p"))))
    (build-system meson-build-system)
+   (arguments
+    `(#:phases
+      (modify-phases %standard-phases
+        (add-before 'check 'pre-check
+          (lambda _
+            ;; Tests require a writable HOME.
+            (setenv "HOME" (getcwd)))))))
    (native-inputs
     `(("gettext" ,gettext-minimal)
       ("glib:bin" ,glib "bin")