summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-04 22:40:42 +0800
committerAndrew Tropin <andrew@trop.in>2023-07-10 10:54:48 +0400
commit44b6d26f2d388044650fb65da83c7027c8bcad58 (patch)
tree40f9f44d0049bb76d125901b6685b7fd5e77dd43 /gnu/packages
parent6663eb9aa7c438f011498fdd7caa0d46ffbab984 (diff)
downloadguix-44b6d26f2d388044650fb65da83c7027c8bcad58.tar.gz
gnu: Add emacs-eglot-x.
* gnu/packages/emacs-xyz.scm (emacs-eglot-x): New variable.

Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8c688c186c..fb36d7d29d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18545,6 +18545,30 @@ for the current file, using the major mode as a hint.  It prompts you to enter
 one if it fails.")
     (license license:gpl3+)))
 
+(define-public emacs-eglot-x
+  ;; Not tagged.
+  (let ((commit "a09ab28cf01d7cbb223ad83fbbb694c5158c96b8"))
+    (package
+      (name "emacs-eglot-x")
+      (version "0.6")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/nemethf/eglot-x")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0s17nv59gzgqgskid41lfacsqnzdiq2p3ds0vglcfqwypr3k898c"))))
+      (build-system emacs-build-system)
+      (inputs (list emacs-eglot))
+      (home-page "https://github.com/nemethf/eglot-x")
+      (synopsis "Protocol extensions for Eglot")
+      (description
+       "This package adds support for some LSP extensions to @code{emacs-eglot}.
+")
+      (license license:gpl3+))))
+
 (define-public emacs-jabber
   ;; No releases available.
   (let ((commit "af0315e174fa6446d5c4dd3e6465d48912950e58")