summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-24 12:01:41 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-02 08:00:15 +0100
commit4a0549be52f3f46fbce61342d8de30f7b83130c5 (patch)
tree115ac29f4ee52f9d8596f67c6bdd593fd61b9edf /gnu/packages
parent0b969af1532ab17c59273ad364ed8f00bb9bed94 (diff)
downloadguix-4a0549be52f3f46fbce61342d8de30f7b83130c5.tar.gz
gnu: Add theft.
* gnu/packages/check.scm (theft): New variable.

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index a3d52427fe..2dcf33a460 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3127,6 +3127,36 @@ retried.")
 allowing you to declaratively define \"match\" rules.")
     (license license:bsd-3)))
 
+(define-public theft
+  (package
+   (name "theft")
+   (version "0.4.5")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/silentbicycle/theft")
+                  (commit (string-append "v" version))))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "1n2mkawfl2bpd4pwy3mdzxwlqjjvb5bdrr2x2gldlyqdwbk7qjhd"))
+            (snippet #~(begin
+                         (delete-file "vendor/greatest.h")))))
+   (build-system gnu-build-system)
+   (arguments (list #:make-flags #~(list "VENDOR="
+                                         (string-append "CC=" #$(cc-for-target))
+                                         (string-append "PREFIX=" #$output))
+                    #:test-target "test"
+                    #:phases
+                    #~(modify-phases %standard-phases
+                        (delete 'bootstrap)
+                        (delete 'configure))))
+   (native-inputs (list greatest))
+   (home-page "https://github.com/silentbicycle/theft")
+   (synopsis "Property-based testing for C")
+   (description "Theft is a library for property-based testing.")
+   (license license:isc)))
+
 (define-public unittest-cpp
   (package
     (name "unittest-cpp")