summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-03-02 01:00:35 +0100
committerKei Kebreau <kei@openmailbox.org>2017-03-04 16:30:36 -0500
commit52c14bb6ec6fbd532b1e03a512d133e2499186b9 (patch)
tree4d5d4ed2bd53ef924df378a9b5f3aafeabddf8bd /gnu/packages
parent3190c307f95fc5f289c1aa8a3955a58e1a5ca4b2 (diff)
downloadguix-52c14bb6ec6fbd532b1e03a512d133e2499186b9.tar.gz
gnu: pugixml: Build relocatable library.
* gnu/packages/xml.scm (pugixml): Add "-shared -fPIC" to ensure the
library is relocatable.

Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xml.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 9a22535c28..6ec2b1fdc9 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -803,7 +803,9 @@ the form of functions.")
         "0fcgggry5x5bn0zhb09ij9hb0p45nb0sv0d9fw3cm1cf62hp9n80"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f))                    ; no tests
+     `(#:configure-flags '("-DCMAKE_CXX_FLAGS=-shared -fPIC"
+                           "-DCMAKE_C_FLAGS=-shared -fPIC")
+       #:tests? #f))                    ; no tests
     (home-page "http://pugixml.org")
     (synopsis "Light-weight, simple and fast XML parser for C++ with XPath support")
     (description