summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-06-22 12:57:56 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-06-22 12:58:49 +0200
commit545946f6571c3dd01a450de738e2b37bdf148061 (patch)
tree458489ba9a5050e403430535cf898af0d4826478 /gnu/packages
parenta6175442481c3d0594453e90c51bb5dafe539d2a (diff)
downloadguix-545946f6571c3dd01a450de738e2b37bdf148061.tar.gz
gnu: Add openvr.
* gnu/packages/game-development.scm (openvr): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/game-development.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 63ccd20470..1fb90b95d3 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1511,3 +1511,29 @@ added.  The permanent goal is to create the open source Quake 3 distribution
 upon which people base their games, ports to new platforms, and other
 projects.")
       (license license:gpl2))))
+
+(define-public openvr
+  (package
+    (name "openvr")
+    (version "1.4.18")
+    (home-page "https://github.com/ValveSoftware/openvr/")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0m92634j6g0f2xybbzklm79cnq20vidbk1jc62pnz12aabwixvyh"))))
+    (build-system cmake-build-system)
+    (arguments
+     ;; No tests.
+     '(#:tests? #f
+       #:configure-flags (list "-DBUILD_SHARED=1")))
+    (synopsis "Virtual reality software development kit")
+    (description "OpenVR is an API and runtime that allows access to VR
+hardware from multiple vendors without requiring that applications have
+specific knowledge of the hardware they are targeting.")
+    (license license:bsd-3)))